LFS and apt

Peter Haack peterhaack01 at yahoo.de
Fri Sep 7 03:03:56 PDT 2007

support schrieb:
> Hi, Peter - 

> Ah, ok.  For a minute there I thought you might have assumed that apt was 
> yet another brain-dead software update app. 
> I had to create an apt.conf as apt kept bombing every time I used more than 
> a handful of mirrors; all of my systems are "mixed", so I need at least two 
> sets.  The other thing it does is establish which release is your default 
> (etch, lenny, or sid); here's mine: 
> APT::Default-Release "stable";
> APT::Cache-Limit "8388608"; 
> Two questions: what does "apt-cache policy" say that apt is going to try to 
> download?  And, when you say they're getting downloaded but not installed - 
> does dpkg -L name-of-package (eg., dpkg -L net-tools) come back with "the 
> package is not installed", or ??? 
> Is the package at least ending up in /var/cache/apt?  If it is, what happens 
> when you try to manually install it w dpkg? 
> Also, where'd you get the code for apt?  I'm wondering if it's a dependency 
> problem... Here are the libraries apt-get and dpkg are using: 
> $ ldd `which apt-get`
>        libapt-pkg-libc6.3-6.so.3.11 => /usr/lib/libapt-pkg-libc6.3-6.so.3.11 
> (0x00002b655c1f7000)
>        libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0x00002b655c3b8000)
>        libm.so.6 => /lib/libm.so.6 (0x00002b655c5b7000)
>        libgcc_s.so.1 => /lib/libgcc_s.so.1 (0x00002b655c739000)
>        libc.so.6 => /lib/libc.so.6 (0x00002b655c846000)
>        /lib64/ld-linux-x86-64.so.2 (0x00002b655c0df000) 
> $ ldd `which dpkg`
>        libpthread.so.0 => /lib/libpthread.so.0 (0x00002b8bee0f3000)
>        libc.so.6 => /lib/libc.so.6 (0x00002b8bee208000)
>        /lib64/ld-linux-x86-64.so.2 (0x00002b8bedfdb000) 
> I just checked several of them, they all seem to be using pretty much the 
> same libraries. 
> Is it a case where you do an: 
> $ apt-get update 
> $ apt-get -y install whatever 
> and it downloads the thing but then abends before it installs it?  If so, 
> what does apt's output say?  Do you have gpg keys enabled? 
> What does dpkg say the state of the package is afterwards (partially 
> installed, etc.?) (dpkg --list | grep packagename) 
> I'm curious as to how you make out with this; I can think of a number of 
> things it'd be terrific for (why reinvent the wheel...). 
>  - Larry 
Hi, Larry,
I made things work! :)
I edited the apt.conf like this:

DPkg::Options:: "--force-architecture";

So apt didn`t matter about the architecture (it was always hanging up 
with "package architecture (i386) does not match system" before)

Then I ran apt-get update, and the packages were downloaded in 

But I still couldn`t install with apt. Too much dendencie problems. So I 
  installed with dpkg:

dpkg --force-architecture --force-depends <package>

After all required packages were installed, I made apt-get upgrade && 
apt-get dist-upgrade, and it worked.

But I`m not very happy with this situation. Running dpkg with the 
--force option is not a good idea, don`t you think?
I`m about to do it all again from the beginning. But there is one thing 
I don`t understand:

My Architecture is i686. The packages that are downloaded are i386. Why 
does that no match? I thought i686 is compatible with i386?
I don`t know another way to deal with this than using the 
"--force-architecture" option.

btw: the "ldd" command is very helpful. I didn`t know that before.

  - greets, Peter

More information about the lfs-support mailing list