startup problem: system boots, /etc/rc.d/init.d/sysklogd "hangs": is there a good way to debug this?

Dan Nicholson dbn.lists at gmail.com
Tue Sep 4 22:12:47 PDT 2007


On 9/4/07, support <support at cslimits.net> wrote:
>
> The problem I'm having is this: when the system hits sysklogd in what
> appears to be runlevel 3 and runs "/etc/rc.d/init.d/sysklogd start", the
> machine just sits there.  It's not locked up; it'll respond to
> <ctrl><alt><del> && the caps lock light still works on the keyboard.  I
> can't ^c out of the service though.
>
> sysklogd prints my message && "Starting system log daemon", then nothing;
> the system just sits there...  Unfortunately for me I'm not leaving much in
> the way of a trail because the system log daemon isn't running yet.
>
> Does this sound familiar to anyone, and/or can anybody think of a good way
> to go about debugging this?  I tried running the binary "syslogd" already;
> it seems to run fine in the chroot().  Best I can think of is to start
> hacking at /etc/rc.d/init.d/functions && putting print stmts in it until I
> (hopefully) find out where it's dying - I'm really hoping somebody can come
> up with something better than that...

Before adding debugging to the functions, try booting to single user
mode (level 1). Just add 1 to the kernel command line in grub. This
should (hopefully) get you to a shell. Then you can try running
syslogd and klogd from the command line. Try running "syslogd -d".
That should give you some info. If that's not promising, check the
output of dmesg to see if there's anything in the kernel messages.

--
Dan



More information about the lfs-support mailing list