Two problems with first boot

Juergen Beisert juergen127 at kreuzholzen.de
Thu Nov 1 08:12:40 PDT 2007


On Saturday 27 October 2007 06:28, Gerald Sherette wrote:
>    First I want thank everyone involved with LFS/BLFS  for their hard work.
> These projects are excellent.
>
>     I just finished building LFS 6.3 using the LiveCD x86-63-r2052 as host.
>  I cut and pasted the instructions on from the LFS book on the CD.
> Everything seemed to go smoothly until I booted into my new LFS.
>
>  1)   The first thing I noticed was that "Setting up the Linux console "
> gave a red FAIL instead of a green OK.
>
>   2)   Second,  instead of ending with the expected
>  Host login:
>      (where Host is the name of my machine)
>     I get
>  Host login: sda1 sda2 sda3 sda4  <sda5>
>  sd 0:0:0:0: [sda] Attached SCSI disk
>
>     Pressing return, gave the "Host login: " prompt on the next line. I was
> then able to login normally and everything seemed to work. (This box does
> have an external USB hard drive plugged in.  Of course unplugging it gets
> rid of the extra lines but one of my main objectives in doing this build
> was to learn enough to eventually build and boot from an external drive.)
>
> 1)   In investigating  the "Setting up Linux console" problem,  the line
>
> loadkeys ${KEYMAP} >/dev/null 2>&1
>
>    in the bootscript init.d/console appeared to give the FAIL.
>    I replaced it with
>
> #loadkeys ${KEYMAP} >/dev/null 2>&1
> loadkeys -d >/dev/null 2>&1
>
>   to get the default for ${KEYMAP}. Its prior value was "en".
>   I now get OK as the result but haven't a clue about what I did wrong.
>
> 2)   As to the late arriving USB/SCSI messages,  I have tried various
> kernel configurations and boot options with no luck.  The
> CONFIG_SCSI_SCAN_ASYNC and CONFIG_SCSI_WAIT_SCAN sound revelant and though
> they change timing of message arrival, the messages still show up after the
> first Host login: Any suggestions of something to try would be greatly
> appreciated.

Its only a message that your USB subsystem has found a harddisk and was 
successfull when reading the partition table. You are in luck, you now can 
mount it! ;-)

> Please help while I still have some hair left.

Extend your kernel command line with "loglevel=1" and/or "quiet". This will 
stop many kernel messages to become visible on the console.

Hope it helps.
Juergen



More information about the lfs-support mailing list