Text stops before end of screen

Colin Kemp colin at greenballenterprises.net
Wed Jun 13 14:59:13 PDT 2007


On Jun 13, 2007, at 5:53 PM, Ken Moffat wrote:

> On Wed, Jun 13, 2007 at 05:27:23PM -0400, Colin Kemp wrote:
>> Hello
>>
>> im building LFS 6.1.1 and am at the part with the chroot. the chroot
>> works fine, but when i type commands, the text wraps to the next line
>> after filling about half the screen. this only happens with commands,
>> everything else is displayed normally. I am using the livecd 6.1.1-4
>> as a host. Any help is appreciated, as i have built LFS many times
>> and this is the first time this has happened, and i really dont want
>> to start over again :-)
>>
>  Maybe $TERM has become corrupted ?  I regularly build in urxvt (a
> better xterm, if you like, but not recognised by ncurses' terminfo)
> and the command lines don't wrap to a new line.
>
>  But, the thought of building such an old version horrifies me!
>
>  Also, as I said to somebody else a few days ago in slightly
> different terms - if you stay with LFS (and I'm pleased you do),
> you really need to write scripts.  Yes, for a first build just type
> it in to learn.  But the thought of typing in each command line
> for repeated builds scares me.  Some people use jhalfs, others write
> their own scripts.  And yes, updating scripts to catch the changes
> from one release to the next takes time, but with modern browsers it
> is far easier than "blindly" typing the text and sometimes thinking
> "I don't remember doing that before", and helps you see what did
> change.
>
> ĸen
> --  
> das eine Mal als Tragödie, das andere Mal als Farce
> --  
> http://linuxfromscratch.org/mailman/listinfo/lfs-support
> FAQ: http://www.linuxfromscratch.org/lfs/faq.html
> Unsubscribe: See the above information page

actually i had used a script to get me set up in the chroot, since i  
have to shutdown and resume my computer fairly often.... so the set  
up is scripted, which i at first considered to be my problem, but i  
checked and my scripts are right so.... jhalfs never really worked  
for me, and thats why i dont use it. I build 6.1.1 because it  
provides a good host for 6.2, (the 6.2 livecd doesnt detect my video  
card correctly or something, because the screen will go blank after  
about 10 minutes of nonactivity and stay blank, but the comp itself  
responds, so idk, i just use 6.1.1 as a jump into 6.2). I am  
rebuilding since my HD recently crashed and i had to start over. I'll  
check the $TERM thing though. thanks

----------------
Colin Kemp

GreenBall Enterprises
colin at greenballenterprises.net

Web Hosting
www.greenballenterprises.net
webhosting at greenballenterprises.net

Portals OS
portalsos.sourceforge.net
portalsos at greenballenterprises.net




More information about the lfs-support mailing list