Chapter 6.9 - Glibc Make Install Errors

Tijnema tijnema at gmail.com
Fri Jun 8 16:21:20 PDT 2007


On 6/8/07, Tijnema <tijnema at gmail.com> wrote:
> On 6/8/07, Jonathan Haws <Jonathan.Haws at sdl.usu.edu> wrote:
> > When trying to install the Glibc headers in LFS there are numerous issues.  First, make -k check produces quite a few errors (I will post them all once I run the test again).  Most are nptl, which from what I have read are nothing to worry about.  I am using the LiveCD as the host.  Now down to the real problem:
> >
> > I decided to continue when I read about not worrying about nptl, so the next step is to run:
> >
> > make install
> >
> > When this is run, it fails at the end with these messages:
> >
> > make[2]: Entering directory '/build/gclibc-2.3.6/manual'
> > pwd='pwd'; \
> > no libm-err-tab.pl $pwd/.. > lib-err-tmp
> > /bin/sh: no: command not found <<-----------------I believe the problem is here!
> > make[2]: *** [stamp-libm-err] Error 127
> > make[2]: Leaving directory '/build/glibc-2.3.6/manual'
> > make[1]: *** [manual/subdir_install] Error 2
> > make[1]: Leaving directory '/build/glibc-2.3.6'
> > make: *** [install] Error 2
> > root:/build/glibc-build#
> >
> > I have searched and cannot find a resolution.  I can't continue, obviously without working headers, so I could use some expert help.  Thanks in advance!
> >
> > Jonathan R. Haws
> > Jonathan.Haws at sdl.usu.edu
>
> Seems like the symlink to bash is missing, try this:
> ln -s bash /bin/sh
>
> That would create the required symlink, and your install command
> should run fine.
>
> Tijnema

Ok, forgive me pls :P I must be sleeping when making this post...

Tijnema
>



More information about the lfs-support mailing list