Step 6.5 Fails, MKDIR can't find libc V2.4

f001error f001error at gmail.com
Mon Jan 29 21:36:19 PST 2007


G'day,

This is my first time trying to bulid linux, and my second attempt to
use this mailing list, hopefully this message will go somewhere, sry
if this is a double post =P.

I'm up to stage 6.5 "Creating Directories" in the current LFS manual.

The all of the MKDIR fails, to make sure its not a typo i copied and
pasted directly into my terminal window:

mkdir -pv /{bin,boot,etc/opt,home,lib,mnt,opt}

and got this error message:

MKDIR /tools/lib/libc.so.6 Version 2.4 not found (requried by MKDIR)

So figuring it was something screwy with libc I recomplied it and got
a errors when I did a make check (see below). These errors may not be
important as the books says you really don't need to run checks until
chapter 6, and libc is complied back in chapter 5. What is intresting
however is that in chapter 3 section 2 when we are told what modules
to download we are told to download version 2.3.6. So...why would
MKDIR trying to use version 2.4 ? I'm just guessing but could an
environmental varaible of leaked in and now MKDIR is linked against
the wrong version of glibc ? If so how do i check/fix it ?

Here's the make check errors for libc when i complie in chapter 5 section 6.

make[2] [/mnt/lfs/sources/glibc-build/stdio-common/tstdiomisc.out error 1

make[2] leaving directory /mnt/lfs/sources/glibc-build/stdio-common/

make[1] **** [ stdio-common/test] error 2

make [1] leaving directory '/mnt/lfs/sources/glibc-2.3.6'

Cheers

Hope someone can help me



More information about the lfs-support mailing list