First Build - in trouble

Slackrat slackrat4Q at azurservers.com
Sat Jan 20 10:19:34 PST 2007


I downloaded the LFS ISO

I used the LFS ISO as host as I no longer trust the Linux Distro I
have installed and am set to dump it as soon as I can

Single drive Toshiba M40 Laptop with drive partitioned:
HDA1        NTFS   Windows Bootable
HDA2        WIN95/VFAT  Windows/Linux non Bootable storage
HDA3        REISER  Linux Bootable
HDA4        REISER  Linux non Bootable storage
SWAP        NONE - was advised of potential problems on laptop

I installed LFS into /devhda4/LINUX_FROM_SCRATCH/ after making hda4
bootable

No problems on the compiles and only a minor one switching from LILO
to GRUB

menu.lst is as follows: 
Begin /boot/grub/menu.lst
# By default boot the first menu entry.
default 0

# Allow 30 seconds before booting the default.
timeout 30

# Use prettier colors.
color green/black light-green/black

# The first entry is for LFS.
title LFS 6.2 LFS-DIR
root (hd0,3)
kernel /LINUX_FROM_SCRATCH/boot/lfskernel-2.6.16.35 root=/dev/hda4/LINUX_FROM_SCRATCH

# Boot DOS
title Win$hit
rootnoverify (hd0,0)
chainloader +1

# Boot Linux 
title Slack
root (hd0,2)
kernel /boot/vmlinuz root=/dev/hda3 vga=773 ro

# Boot Memory Test 
title Memory Test 
root (hd0,2)
kernel /memtest/memtest.bin

# EOF

LFS does not boot

The other three choices do boot

I have also moved - using 'cp' - all of the LINUX_FROM_SCRATCH directory
into the root of hda4 to see if this would work

This does not work either

I modified 'menu.lst' to reflect the change in location

I  used fdisk to make hda4 bootable then made the LINUX_FROM_SCRATCH
directory but since it was already formatted Reiser, I ignored the
instructions to make the EXT2 filesystem

Any advise on what I can try next please?

Does LFS have to be on a partition that already has a working system
on it?

I had no problems with the actual compiling of the files

-- 
Regards, Slackrat [Bill Henderson] [No _4Q_ for direct email]



More information about the lfs-support mailing list