LFS 6.2 - 6.7.1. Installation of Linux-Libc-Headers

Aleksandar Adam zoffmann at linuxmail.org
Mon Jan 15 03:56:23 PST 2007


> But you didn't tell us *what* error message you got, so nobody can
> give you a reasonable suggestion about what is wrong!


Here comes output what went wrong:
I used command:

patch -Np1 -i ../linux-libc-headers-2.6.12.0-inotify-3.patch | tee patch.txt

and then I get this:

can't find file to patch at input line 12
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|Submitted By: Dan Nicholson <dnicholson at linuxfromscratch dot org>
|Date: 2006-08-01
|Initial Package Version: 2.6.12.0
|Origin: linux-2.6.16 series, syscalls diffed by Alexander Patrakov
|Upstream Status: Project is dead
|Description: Adds userspace headers and syscalls for inotify
|Testcase: dovecot-1.0rc2, ./configure --with-notify=inotify
|
|diff -pNur linux-libc-headers-2.6.12.0.orig/include/asm-i386/unistd.h linux-libc-headers-2.6.12.0/include/asm-i386/unistd.h
|--- linux-libc-headers-2.6.12.0.orig/include/asm-i386/unistd.h	2005-07-06 00:17:47.000000000 +0000
|+++ linux-libc-headers-2.6.12.0/include/asm-i386/unistd.h	2006-08-01 05:56:42.000000000 +0000
--------------------------
File to patch: 
Skip this patch? [y] 
Skipping patch.
1 out of 1 hunk ignored
can't find file to patch at input line 30
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|diff -pNur linux-libc-headers-2.6.12.0.orig/include/asm-ppc/unistd.h linux-libc-headers-2.6.12.0/include/asm-ppc/unistd.h
|--- linux-libc-headers-2.6.12.0.orig/include/asm-ppc/unistd.h	2005-07-06 00:17:23.000000000 +0000
|+++ linux-libc-headers-2.6.12.0/include/asm-ppc/unistd.h	2006-08-01 05:56:42.000000000 +0000
--------------------------
File to patch: 
Skip this patch? [y] 
Skipping patch.
1 out of 1 hunk ignored
The next patch would create the file include/linux/inotify.h,
which already exists!  Skipping patch.
1 out of 1 hunk ignored -- saving rejects to file include/linux/inotify.h.rej


I have used patch which is suggested in the book, and I found it on lfs-live cdrom.
Best regards
Aleksandar







> ----- Original Message -----
> From: "Ken Moffat" <ken at linuxfromscratch.org>
> To: "LFS Support List" <lfs-support at linuxfromscratch.org>
> Subject: Re: LFS 6.2 - 6.7.1. Installation of Linux-Libc-Headers
> Date: Mon, 15 Jan 2007 01:08:06 +0000
> 
> On Mon, Jan 15, 2007 at 06:00:53AM +0800, Aleksandar Adam wrote:
> > Hi,
> > I am reading LFS book 6.2 (look at the chapter 6.7.1 - 
> > Installation of Linux-Libc-Headers) and trying to aply aply 
> > following patch:
> >
> > patch -Np1 -i ../linux-libc-headers-2.6.12.0-inotify-3.patch
> >
> > but I got the error.

> 
> > My question is: do I need this patch and can I continue without it?
> >
> > best regards
> > Aleksandar
> >
>   For a desktop, you probably want it.  For a server, you might
> manage without it.  But, it should apply without any problems.
> Without knowing the error, all I can suggest is that you make sure
> the version of the patch which you have downloaded is the correct
> patch.
> 
> ĸen
> --
> das eine Mal als Tragödie, das andere Mal als Farce
> --
> http://linuxfromscratch.org/mailman/listinfo/lfs-support
> FAQ: http://www.linuxfromscratch.org/lfs/faq.html
> Unsubscribe: See the above information page

>


-- 
_______________________________________________
Search for products and services at: 
http://search.mail.com

Powered by Outblaze



More information about the lfs-support mailing list