IPRoute2-2.6.16: arpd.c compiling error

Dan Nicholson dbn.lists at gmail.com
Thu Jan 4 10:04:34 PST 2007


On 1/4/07, Mauricio Casanova <mcasanov at gmail.com> wrote:
> Dan Nicholson escribió:
> >
> > Something has gone wrong with your Berkeley DB installation because
> > you should have /usr/include/db_185.h. Maybe run a `find /usr/include
> > -name db_185.h' to see if it's there but in a different directory.
> >
> I've run a 'find ...' and doesn't find it.
> What I did, previous to your response because didn't know the
> dependencies for Berkeley DB libraries, was to skip the installation of
> arpd and go through the installation of rest of the softwares.

You should check that Berkeley DB is installed. Maybe it got into
/usr/local somehow. The man-db package is the only critical
application that depends on db. I suspect that db is installed
somewhere since otherwise I think that the man-db build would bomb.

--
Dan



More information about the lfs-support mailing list