binutils pass1 ld-new not there?

Karen Karenslfs karenslfs at
Mon Feb 26 13:34:23 PST 2007

On 2/27/07, Dan Nicholson <dbn.lists at> wrote:
> On 2/26/07, Karen Karenslfs <karenslfs at> wrote:
> >
> > It worked!!! thanks so much.
> Glad it worked out. Another project run by a former LFSer called DIY
> Linux always adds the workarounds at the beginning. Maybe we should
> start doing the same.

> > make[1]: Leaving directory `/mnt/lfs/sources/gcc-build'
> > bash-3.1$ echo $?
> > 0
> > bash-3.1$ false
> > bash-3.1$ echo $?
> > 1
> > bash-3.1$ echo $?
> > 0
> > bash-3.1$
> Oops, you've taken me a bit too literally. The first $? is 0, so the
> previous command (make -C ld ...) was successful. The other commands
> were just an example I posted to show how things work. If you call the
> command `false', it will always return 1. Vice versa with `true'. So,
> just the first `echo $?' is needed.
> Normally, output from `make' should be pretty clear whether there was
> an error or not. $? is just a sure way to check status.

Oops silly me:-) Then it seems thanks to you, I'm getting through gcc.
 Hopefully if I can get through chpt 5 I'll be substantially free of
the host fc6 (save the kernel) & it's "endless stuff" won't trip me.
Can't wait.

I guess your problem with including workarounds is that you would need
so many host specific & given that so far even I seem to be OK with
the book it might just confuse us novices more. I'm sick of fc not
doing what I want & it seems having no fix available.

All very much appreciated.


More information about the lfs-support mailing list