binutils pass1 ld-new not there?

Dan Nicholson dbn.lists at
Mon Feb 26 11:47:12 PST 2007

On 2/26/07, Karen Karenslfs <karenslfs at> wrote:
> It worked!!! thanks so much.

Glad it worked out. Another project run by a former LFSer called DIY
Linux always adds the workarounds at the beginning. Maybe we should
start doing the same.

> Finished the make bootstrap, but novice still a little confused.
> Below is the end of the make bootstrap output & I then your  suggested
> echo $? but I'm not sure if this is good or bad. The first return is
> "0" but the second is "1", does this confirm or otherwise that the
> make bootstrap was successful??


> make[1]: Leaving directory `/mnt/lfs/sources/gcc-build'
> bash-3.1$ echo $?
> 0
> bash-3.1$ false
> bash-3.1$ echo $?
> 1
> bash-3.1$ echo $?
> 0
> bash-3.1$

Oops, you've taken me a bit too literally. The first $? is 0, so the
previous command (make -C ld ...) was successful. The other commands
were just an example I posted to show how things work. If you call the
command `false', it will always return 1. Vice versa with `true'. So,
just the first `echo $?' is needed.

Normally, output from `make' should be pretty clear whether there was
an error or not. $? is just a sure way to check status.


More information about the lfs-support mailing list