GRUB hosed, frantic

Karl Wilbur karl at
Sat Feb 10 16:44:16 PST 2007

Colin Dean wrote:
> So, I somehow managed to hose GRUB on /dev/hda1 while attempting to 
> install it to a flash drive on /dev/sda1.
> After POST, I see

This means that the "setup (hd0)" command worked and grub is installed
in the MBR of that hard drive, but grub cannot find the the grub
directory. Do you have a separate boot partition?

> I tried to boot from the LFS CD and redo the grub installation:
> $ grub
> grub> root (hd0,0)
> grub> setup (hd0)
> but it tells me that it cannot find a file when it is installing the 
> stage files and /boot/grub/menu.lst.

Did you create a separate boot partition?

If so, did you mount it?

> When I try:
> $ grub-install --no-floppy /dev/hda1
> it tells me that /dev/hda1 is a read-only file system, regardless of 
> whether or not I have it mounted.

Is hda an actual hard in not a CD/DVD drive?
hda = primary master in most cases

In grub,  "hd0" = first hard disk and "hd1" =  second hard disk (optical
drives are skipped). Also:

hd0,0 = first partition on first hard disk
hd0,1 = second partition on first hard disk
and so on.

> Ideas/help/anything welcome.

try booting back into the LFS CD, mounting hard drive partitions as
needed, and running grub again. Type:

root (hd0,

and press the tab key. You will see the available partitions. make sure
that you select the correct one for your boot partition. HTH.

Karl Wilbur

More information about the lfs-support mailing list