John Harrigan jfharrigan at fedex.com
Thu Feb 8 15:17:05 PST 2007

* Dan Nicholson <dbn.lists at gmail.com>:
> On 2/8/07, John Harrigan <jfharrigan at fedex.com> wrote:
> > * Galaxy Travel <giftbound at verizon.net>:
> > > I deleted the headers on mistake, Now I tryed to reinstall the headers and
> > > it looks like it wont let me, So do I have to reinstall everything again?
> >
> > I'm assuming you're using the newer 'make headers_install' method
> > because I ran into the same problem.  Fortunately, I had a backup
> > so I didn't have to try this method.
> Could you guys actually show what the problem is?

When you try to run 'make headers_install' without pre-existing
linux headers (linux/limits.h for example) the build fails because
of missing includes.  I personally ran into the problem because
I upgraded kernels, then removed all the previous kernel's includes,
and finally tried to install the headers for the new kernel.  I should
not have removed the previous kernel's headers before trying to build
the new kernels headers.

More information about the lfs-support mailing list