John Harrigan jfharrigan at fedex.com
Thu Feb 8 15:03:16 PST 2007

* To lfs-support at linuxfromscratch.org <jfharrigan at fedex.com>:
> * Galaxy Travel <giftbound at verizon.net>:
> > I deleted the headers on mistake, Now I tryed to reinstall the headers and 
> > it looks like it wont let me, So do I have to reinstall everything again? 
> > 
> I'm assuming you're using the newer 'make headers_install' method
> because I ran into the same problem.  Fortunately, I had a backup
> so I didn't have to try this method.
> You might be able to temporarily install the linux-libc-headers
> package and use those just long enough to build the new headers.
> http://ep09.pld-linux.org/~mmazur/linux-libc-headers/
> If you untar those includes somewhere, you should be able to point your
> include path to them (using CPPFLAGS or LINUXINCLUDE) while you build
> the new headers.  Again, it's only an idea, I haven't actually tried
> this.

I tried a quick test, and it appears that setting CPPFLAGS and/or
LINUXINCLUDE on the make command line don't have any effect.  I added
my -I explicitly to the HOSTCC variable in the top level Makefile and
that seemed to work.  Also, after you untar the libc-headers package,
you have to rename the 'include/asm-i386' directory to just 'include/asm'
(substituting i386 with your platform of course).

With those two steps I was able to run a complete 'make headers_install'
without a /usr/include/linux directory.

More information about the lfs-support mailing list