Grub settings for sda, hda (VMWare)

Vladimir A. Pavlov pv4 at
Sat Oct 28 14:47:23 PDT 2006

On Sunday 29 October 2006 00:43, lanas wrote:
> Folks,
>   Using VMware, I've installed LFS from the Live CD 6.1.1 (nalfs).  The
> VM already has SuSE 10.0 32 bits on the main VMWare drive sda and LFS
> was installed on the next drive, hda.  Would hda then be the second
> drive in grub and if so, would it follow the same naming convention
> eg. sda = hd0, hda = hd1 ?  
>   Here are the two grub menu.lst entries:
> title SUSE LINUX 10.0
>     root (hd0,0)
>     kernel /boot/vmlinuz root=/dev/sda1 vga=0x336 selinux=0 
>     initrd /boot/initrd
> title LFS 6.1.1
>     root (hd1,0)
>     kernel /boot/lfskernel- root=/dev/hda1
>   This yields the following error when the LFS entry is chosen at boot
> time:
>   kernel /boot/lfskernel- root=/dev/hda1
>   Error 15: file not found
>   I've also tried 'root (hd0,0)' for the LFS entry, but still the same
> error.
>   Any ideas ?

"info grub" gives

15 : File not found
     This error is returned if the specified file name cannot be found,
     but everything else (like the disk/partition info) is OK.

Try pressing 'c' upon grub prompt to access grub command line. Then
you'd be able to play with <tab> key and see what partition/path you
should use.

Type "kernel (hd1," and press <tab> to see the full list of possible
partitions. Having chosen one you can still use <tab> for further
"moving" through directories.

For your case try to type "kernel (hd1,0)/" adn press <tab> one or more
times to see what directories exist on the partition. Especially make
sure /boot/lfskernel- does exist on the selected partition.

Nothing but perfection

More information about the lfs-support mailing list