Error during the make install in section 6.9.2 (Install glibc)

Vladimir Marcu vmarcu at
Tue Oct 10 18:50:23 PDT 2006


I was working on section 6.9.2 (re-installing glibc in chapter 6) - and it
went all well for the first part. I ran the test and the only errors I got
were for failing the nptl/tst-clock2 and tst-attr3 tests. According to the
book this is a known problem and I am blaming it on the slow hardware I am
using (old Toshiba laptop with a PII processor at 266 MHz with 62 MB RAM (64
actually but 2 for the onboard video). Also, I am using the LFS LiveCD.
I then issued the touch /etc/ command.
Then, make install. At this point I got an error message complaining about
the fact that /usr/bin/ is not a directory. I don't know what this
means or what impact it will have if I continue with building the system.

make  -C: iconv subdir_install
make[2]: Entering directory `/sources/glibc-2.3.6/iconv'
/tools/bin/install -c -m 644 iconv.h /usr/include/iconv.h
/tools/bin/install -c -m 644 gconv.h /usr/include/gconv.h
/tools/bin/install -c /sources/glibc-build/iconv/iconv_prog
/tools/bin/install: accessing `/usr/bin/': Not a directory
make[2]: *** [/usr/bin/iconv] Error 1
make[2]: Leaving directory `/sources/glibc-2.3.6/iconv'
make[1]: *** [iconv/subdir_install] Error 2
make[1]: Leaving directory `/sources/glibc-2.3.6'
make: *** [install] Error 2

I ran a search on google and apparently someone had a similar issue when
installing glibc-2.2.5 in version 4 of the book. He posted the problem on
the lfs-support mailing list in 2002 but I could't find any replies to his

I would also like to note that the search function on the website didn't
seem to work for me. Even if I used a very generic keyword like "glibc" the
search timed out after 10 seconds.


More information about the lfs-support mailing list