GCC-3.4.1-Pass1 problem

Richard Caldwell rcaldwellie at yahoo.com
Mon Oct 2 05:39:38 PDT 2006

----- Original Message ----
From: Chris Staub <chris at beaker67.com>
To: LFS Support List <lfs-support at linuxfromscratch.org>
Sent: Monday, October 2, 2006 3:31:27 AM
Subject: Re: GCC-3.4.1-Pass1 problem

Richard Caldwell wrote:
> Hi,
>   I'm creating my first LFS system with a Suse10.1
> host system using book version 6.0.
> I'm getting the following error when I run 
> make BOOT_LDFLAGS="-static" bootstrap
> *****************
> /tools/i686-pc-linux-gnu/bin/ld:/usr/lib/libc.so: file
> format not recognized; treating as linker script
> /tools/i686-pc-linux-gnu/bin/ld:/usr/lib/libc.so:5:
> syntax error
> collect2: ld returned 1 exit status
> make[3]: *** [libgcc_s.so] Error 1
> make[3]: Leaving directory `/mnt/lfs/gcc-build/gcc'
> make[2]: *** [libgcc.a] Error 2
> make[2]: Leaving directory `/mnt/lfs/gcc-build/gcc'
> make[1]: *** [stage1_build] Error 2
> make[1]: Leaving directory `/mnt/lfs/gcc-build/gcc'
> make: *** [bootstrap] Error 2
> lfs at dhcppc1:/mnt/lfs/gcc-build> 
> ***************************
> when I ran the previous command ../configure...... I
> got an error telling me to set the variable CC to a
> working compiler, which I then set using: export
> cc="/usr/bin/cc" but I don't know if this is relevant.
> Any help much appreciated.
> Thanks.

That host system is too new to build that old version of LFS. You need 
to either find an older distro to use as a host, or build the latest 
stable LFS version.
I see that the latest book version online is 6.2, so I wouldn't have thought
that 6.0 was 'very' old. It took me so long to download all of the files 
that I don't want to have to go through that again! Can you recommend
a suitable host? I see suse 9.2 professional available on amazon for 
£6.96. Would that be a suitable distro?

FAQ: http://www.linuxfromscratch.org/lfs/faq.html
Unsubscribe: See the above information page

More information about the lfs-support mailing list