GCC-3.4.1-Pass1 problem

Richard Caldwell rcaldwellie at yahoo.com
Sun Oct 1 11:17:17 PDT 2006


Hi,
  I'm creating my first LFS system with a Suse10.1
host system using book version 6.0.
I'm getting the following error when I run 
make BOOT_LDFLAGS="-static" bootstrap

*****************
/tools/i686-pc-linux-gnu/bin/ld:/usr/lib/libc.so: file
format not recognized; treating as linker script
/tools/i686-pc-linux-gnu/bin/ld:/usr/lib/libc.so:5:
syntax error
collect2: ld returned 1 exit status
make[3]: *** [libgcc_s.so] Error 1
make[3]: Leaving directory `/mnt/lfs/gcc-build/gcc'
make[2]: *** [libgcc.a] Error 2
make[2]: Leaving directory `/mnt/lfs/gcc-build/gcc'
make[1]: *** [stage1_build] Error 2
make[1]: Leaving directory `/mnt/lfs/gcc-build/gcc'
make: *** [bootstrap] Error 2
lfs at dhcppc1:/mnt/lfs/gcc-build> 
***************************
when I ran the previous command ../configure...... I
got an error telling me to set the variable CC to a
working compiler, which I then set using: export
cc="/usr/bin/cc" but I don't know if this is relevant.
Any help much appreciated.
Thanks.
  




More information about the lfs-support mailing list