Problem with su

Romain Thouvenin romain.thouvenin at
Sat Nov 11 05:52:12 PST 2006


I'm installing LFS 6.1.1 from Ubuntu, chapter 6, and I use more
control and package manager.
I got a strange error when I ran the command install_package :

   install_package "Mktemp : pour creer des fichiers temporaires" mktemp mktemp
   su: /usr/src/mktemp:/bin/bash: No such file or directory

Same error if I run su mktemp.
What's strange is that it never happened for previous packages, and I
can still run "su zlib" without problem.

bash exists and linkage seems OK :
root:/# ls -l /bin/bash
lrwxrwxrwx  1 root root 15 Nov  6 23:37 /bin/bash -> /tools/bin/bash
root:/# ldd /bin/bash =>  (0xffffe000) => /tools/lib/ (0xb7eab000) => /tools/lib/ (0xb7ea6000) => /tools/lib/ (0xb7d8c000)
        /tools/lib/ (0xb7eed000)
root:/# ldd /tools/bin/su =>  (0xffffe000) => /tools/lib/ (0xb7ef5000) => /tools/lib/ (0xb7dda000)
        /tools/lib/ (0xb7f24000)

The only difference I can see between this package and previous ones
is that I used a "real" description, not just the name (because I
didn't know mktemp). But the description is the name of the user, so I
can put whatever I want, right ?

I have no idea of what to do. Any clue ?

Thanks for your help,,

More information about the lfs-support mailing list