gcc-3.4.3 bootstrap error

Ken Moffat ken at linuxfromscratch.org
Thu Feb 23 06:41:24 PST 2006


On Thu, 23 Feb 2006, Terror Duizel wrote:

> i did everything as the book says but i get the next error when bootstrap 
> gcc-3.4.3:
>
> mv libgcc_s.so.1.tmp libgcc_s.so.1 && ln -s libgcc_s.so.1 libgcc_s.so
> /tools/i686-pc-linux-gnu/bin/ld:/usr/lib/libc.so: file format not recognized; 
> treating as linker script

  You're right at the start of chapter 5, binutils decided you were 
running on i686, but now it fails to recognize the host's libc ?

> /tools/i686-pc-linux-gnu/bin/ld:/usr/lib/libc.so:5: syntax error

  Is this an ancient libc5 system ?  If it is, it's way too old to build 
LFS.  Or, perhaps, you have some sort of libc5 for compatability with 
very old applications ?

  If it isn't running libc5, what cpu and distro, and what do 'ld -V' 
'gcc -v' and '/lib/libc.so.6' report ?

Ken
-- 
  das eine Mal als Tragödie, das andere Mal als Farce


More information about the lfs-support mailing list