Error while making system bootable

admin at admin at
Wed Feb 15 21:02:18 PST 2006

I can help you with that but first paste your output from cfdisk
so we will know what partitions you are using. 

for the mean time i can give you some example, its better you read the grub 
manual because its all there. 

this is my cfdisk sample output 

hda1                    Primary   Linux swap / Solaris              1003.49
hda2        Boot        Primary   Linux ext3                       10001.95 

this is my /boot/grub/menu.lst 

# Begin /boot/grub/menu.lst 

# By default boot the first menu entry.
default 0 

# Allow 30 seconds before booting the default.
timeout 30 

# Use prettier colors.
color green/black light-green/black 

# The first entry is for LFS.
title LFS 6.1.1
root (hd0,1)
kernel /boot/lfskernel- root=/dev/hda2 

this is my /etc/fstab 

# Begin /etc/fstab 

# file system  mount-point  type   options         dump  fsck
#                                                        order 

/dev/hda2      /            ext3   defaults        1     1
/dev/hda1      swap         swap   pri=1           0     0
proc           /proc        proc   defaults        0     0
sysfs          /sys         sysfs  defaults        0     0
devpts         /dev/pts     devpts gid=4,mode=620  0     0
shm            /dev/shm     tmpfs  defaults        0     0
# End /etc/fstab 

this is my sample grub session 

grub> root (hd0,1)
Filesystem type is ext2fs, partition type 0x83 

grub> setup (hd0)
Checking if "/boot/grub/stage1" exists... yes
Checking if "/boot/grub/stage2" exists... yes
Checking if "/boot/grub/e2fs_stage1_5" exists... yes
Running "embed /boot/grub/e2fs_stage1_5 (hd0)"...  16 sectors are embedded.
Running "install /boot/grub/stage1 (hd0) (hd0)1+16 p 
/boot/grub/menu.lst"... succeeded





kshama shepal writes: 

> Hi everyone! 
>  I m using LFS 6.0
> - I have reached to chapter 8. My kernel installation
> is complete. Now I m trying to   make my lfs sys
> bootable. 
> -For this when I run command ‘root (hd0,2)’ on grub
> prompt it shows error msg ‘specified device does not
> exist’. 
> -Even when I use TAB for command completion, it does
> not list out my hard drive. (Shows only - fd0,cd) 
> -When I try to mount any of the hard drive partition
> on chrooted environment it shows     ‘device does not
> exist’.Nor does it lists any of the partition as
> output of  ‘fdisk –l’ cmd. 
> -at the same time, when I tried same commands on host
> sys,they run well.
>   Like- ‘ root (‘ <TAB>   detects hard drive.
>         ‘fdisk –l’        shows all hard drive
> partitions 
> What the problem could be.
> Please help. 
> __________________________________________________
> Do You Yahoo!?
> Tired of spam?  Yahoo! Mail has the best spam protection around 
> -- 
> FAQ:
> Unsubscribe: See the above information page

More information about the lfs-support mailing list