2.6.14 kernel panic - Cannot open root device "sda1" or unknown- block

Paul Paul at EveryoneSmile.com
Thu Feb 9 14:49:29 PST 2006


I just wanted to say thanks. You were the only one who responded to my post.

I checked my kernel config and you were absolutely right. I didn't have the
scsi block device enabled. When I added it, everything worked fine.

It was difficult to find good documentation to help me troubleshoot my


-----Original Message-----
From: lfs-support-bounces at linuxfromscratch.org
[mailto:lfs-support-bounces at linuxfromscratch.org]On Behalf Of William
Sent: Thursday, February 09, 2006 3:01 PM
To: LFS Support List
Subject: Re: 2.6.14 kernel panic - Cannot open root device "sda1" or
unknown- block

On Feb 9, 2006, at 11:23 AM, Paul wrote:

> My 2.6.14 kernel won't boot. I have tried to document it as best I can
> below. Any help or recommendation would be greatly appreciated
It boots

> Errror Message:
> Cannot open root device "sda1" or unknown-block(0,0)
> Please append a correct "root=" boot option
> Kernel panic - not syncing: VFS: Unable to mount root fs on
> unknown-block(0,0)
can't mount rootfs cause no block devices were detected cause block
device driver isn't in the kernel or your drives died.

> Notes:
> all drivers directly into the kernel (no modules) - not using an
> initrd
> image
> using the Adaptec AACRAID support - SCSI_AACRAID=y
> using the Fusion MPT ScsiHost drivers for SPI - FUSION_SPI=y

missing one: CONFIG_BLK_DEV_SD. The kernel can't talk to scsi block
devices. Try enabling the scsi block device driver in the kernel and
trying again.

If the kernel doesn't find block devices attached to your scsi
drivers that means the drives are dead or you didn't load the block
device driver.


FAQ: http://www.linuxfromscratch.org/lfs/faq.html
Unsubscribe: See the above information page

More information about the lfs-support mailing list