package users and Perl

Randy McMurchy randy at linuxfromscratch.org
Wed Feb 1 07:24:24 PST 2006


Dan Nicholson wrote these words on 02/01/06 09:19 CST:

>  I don't understand how it decides
> between lib/perl5/site_perl and lib/perl5/5.8.7.  Looks like you'll
> have to give write privelages on both.

Almost *always* lib/perl5/5.8.7 is what is installed from the Perl
distribution itself. site_perl is used for add-on modules that are
not part of the Perl distribution. If it doesn't follow that scheme
it is because 1)the module you installed is broken, or 2) the
module you installed is replacing an original distribution module.

-- 
Randy

rmlscsi: [GNU ld version 2.15.94.0.2 20041220] [gcc (GCC) 3.4.3]
[GNU C Library stable release version 2.3.4] [Linux 2.6.10 i686]
09:21:00 up 129 days, 18:45, 3 users, load average: 1.15, 1.09, 0.82



More information about the lfs-support mailing list