package users: re-adjusting the toolchain

Chris Staub chris at beaker67.com
Wed Aug 30 10:18:50 PDT 2006


Brandon Peirce wrote:
> Angel Tsankov wrote:
>>
> For LFS 6.1.1 the instructions says "Install the adjusted linker by 
> running the following command from within the binutils-build directory:"
> The "make -C ld ... install" command is different to the LFS 6.2
> commands but is still manipulating (in 6.1.1 overwriting)
> the linker (ld) from the binutils package so it must still be run
> as your binutils package user.

The adjusted linker is installed into /tools, so you need to use root.

> In 6.1.1 you're still manipulating the same gcc specs file with
> an almost identical command, so it must still be run as your
> gcc package user.

Again, this is done in /tools, so it also should be done as root.



More information about the lfs-support mailing list