upgrade of libc-2.3.3.so to libc-2.3.6.so problematic?

lynx.abraxas at freenet.de lynx.abraxas at freenet.de
Sat Aug 26 00:54:17 PDT 2006


Hallo!


I'm  concidering  upgrading  libc-2.3.3.so  to  libc-2.3.6.so  because of some
structual changes (like sched_getaffinity() to a two parameters  version)  and
this error:
root at linux:~# /lib/libc-2.3.3.so
Inconsistency   detected   by   ld.so:   rtld.c:   1303:   dl_main:  Assertion
`_rtld_local._dl_rtld_map.l_prev->l_next  ==  _rtld_local._dl_rtld_map.l_next'
failed!

In  the  FAQ  it  says: "Another rule of thumb is: don't upgrade the toolchain
(gcc, glibc and binutils)"
But in the introduction of BLFS is says: "For micro version updates, a  simple
reinstallation usually works"

I would like to have some advice on this. Should I do the upgrade? And if, are
there any special steps necessary? (like I found in a mail:  configure;  make;
init 1; make install; init 3)

I have an LFS 5.1.1 and don't want to do a new one from scratch.
Just out of interest: What happens if one does an glibc-upgrade in gentoo?


Thanks for any help
Lynx






More information about the lfs-support mailing list