LFS 6.2 Chapter 6 step 6.9 glibc-2.3.6 configure can't link to gcc

Mike Murfin mike_murfin at hotmail.com
Sun Aug 20 06:37:35 PDT 2006


When I run the configure script, it fails with the message:  "error: cannot compute suffix of object files"

In config.log, I have:

configure:2361: checking for gcc
configure:2377: found /tools/bin/gcc
configure:2387: result: gcc
configure:2631: checking for C compiler version
configure:2634: gcc --version </dev/null/>&5
../glibc-2.3.6/configure: line 2635: /tools/bin/gcc: No such file or directory

I have been back to Chapter 5 step '5.11 gcc-4.0.3 - Pass 2' and double checked everything, and even rebuilt the temporary system from scratch.  At this stage I applied the specs patch.  The results of the dummy compile in the 'caution' section tell me that my program interpreter is /tools/lib/ld-linux.so.2, so it would appear that the build of gcc has worked.

Before running the configure in step 6.9, I extracted glibc-libidn into the glibc source directory and applied the patches for linux-types and inotify as per the book.

I have checked the result of the sed command in step '5.7 Adjusting the Toolchain'.  In the specs file, ($LFS/tools/lib/gcc/i686-pc-linux-gnu/4.0.3/specs) there is only one entry for ld-linux.so.2, as follows:

*dynamic linker:

So, /tools/bin/gcc exists, but the configure script for glibc doesn't seem to be able to use it. 

Any suggestions/pointers would be gratefully accepted!
Be one of the first to try Windows Live Mail.

More information about the lfs-support mailing list