LFS 6.2 -> gcc-4.0.3 error during ompilation

Mag. Leonhard Landrock 1977-Hamlet at gmx.at
Mon Aug 14 11:44:31 PDT 2006


Am Montag, 14. August 2006 20:03 schrieb fleole at free.fr:
> Hi,
>
> I follow the instruction to mount a LFS 6.2 system inside a VMware.
> I use the LFS ISO to boot and everything is fine until the chapter 6.12.1.
>
> The compilation of gcc end by this error :
>
> [url=http://imageshack.us][img=http://img132.imageshack.us/img132/8898/erro
>rmakebmpit1.jpg][/url]
>
>
> Someone have an idea of what happen exactly ??

Take a look 
at "http://linuxfromscratch.org/pipermail/lfs-support/2006-May/030766.html" 
and try to find out, wether you have the same problem I had. From my last 
e-mail to the list 
("http://linuxfromscratch.org/pipermail/lfs-support/2006-August/031241.html") 
you can see, that I finaly came around the problem.

I am sorry to say, that I just can give some hints where the error might come 
from but no real proof.

My hints:

1.) Be sure to use the stable LFS book. ;-)
2.) Be sure to have a clean temporary system (Part II. Preparing for the 
Build).
3.) Be sure not to mix any packages: "After installing each package, delete 
its source and build directories, unless specifically instructed otherwise. 
Deleting the sources prevents mis-configuration when the same package is 
reinstalled later."

I do rename each package before starting a new build. -> For example I have 
an "gcc-build_1" and a "gcc-build_2" directory.

4.) Maybe there is the need to take a break and start right from the beginning 
once again. :-(  Sorry.

> Regards

Kind reagards,
Leonhard.



More information about the lfs-support mailing list