lfs-support Digest, Vol 1046, Issue 1

Jeremy Henty jeremy at chaos.org.uk
Sun Aug 13 10:33:00 PDT 2006


On Fri, Aug 11, 2006 at 11:23:31PM -0700, Paul G Rogers wrote:
> >From: Jeremy Henty <jeremy at chaos.org.uk>
> >I run LFS-6.1.1 , upgraded to kernel-2.6.16.27 and udev-071 .  Can
> >I upgrade to udev-096 using the LFS-6.2 instructions or will it
> >break
> 
> I did and nary a squeak.  Though I was on an old classic Pentium
> system without much of an I/O challenge.

OK, I upgraded and *nearly* got it completely right first time.
Nothing actually broke, but I was plagued by messages about "bad
message magic udevd_071" when booting up or shutting down.  For the
record, I had tripped over two gotchas:

  * I needed to run "make uninstall" in the udev-071 build tree before
    installing udev-096.  If you don't do that then something in the
    old udev-071 installation gets triggered during the boot.

  * I needed to disable hotplug.  (I inserted "exit 0" at the top of
    the bootscript.)

After fixing those two issues everything works perfectly.

Regards, 

Jeremy Henty 



More information about the lfs-support mailing list