Problem with building Perl-5.8.8 in section 6.2.2

Chris Staub chris at
Thu Aug 10 12:46:13 PDT 2006

Don Clarke wrote:
> Thanks to everyone for the responses.
> I've solved the problem and I think I know what caused it and what the
> solution was.
> I think the problem was caused by running the following in the LFS:
> ./configure.gnu --prefix=/usr \
>     -Dman1dir=/usr/share/man/man1 \
>     -Dman3dir=/usr/share/man/man3 \
>     -Dpager="/usr/bin/less -isR"
> Last night I tried again but used the "./Configure" option. Once built I ran
> the built "autoconf" and it worked!
> I noticed that there was an option to include old library paths in @INC
> which in "./Configure" the default is not to include but I suspect in the
> "./configure.gnu" script the default is to include ...
> Hope this helps.
> Don.

If the "configure.gnu" command in the book didn't work, then something 
in your system is broken. If you want to continue you're welcome to try, 
but the fact is you really *don't* know what the problem was and you're 
likely to run into more.

More information about the lfs-support mailing list