Problem with building Perl-5.8.8 in section 6.2.2

Don Clarke clarkedon at
Thu Aug 10 12:45:04 PDT 2006

Thanks to everyone for the responses.

I've solved the problem and I think I know what caused it and what the
solution was.

I think the problem was caused by running the following in the LFS:

./configure.gnu --prefix=/usr \
    -Dman1dir=/usr/share/man/man1 \
    -Dman3dir=/usr/share/man/man3 \
    -Dpager="/usr/bin/less -isR"

Last night I tried again but used the "./Configure" option. Once built I ran
the built "autoconf" and it worked!

I noticed that there was an option to include old library paths in @INC
which in "./Configure" the default is not to include but I suspect in the
"./configure.gnu" script the default is to include ...

Hope this helps.


-----Original Message-----
From: lfs-support-bounces at
[mailto:lfs-support-bounces at] On Behalf Of Don Clarke
Sent: 09 August 2006 19:17
To: lfs-support at
Subject: Problem with building Perl-5.8.8 in section 6.2.2

I'm building LFS 6.2 and have hit a problem with section 6.2.2

The final build of Perl works fine but when I try to build autoconf
The @INC path has the /tools directory hardwired into it.

I've tried using grep in the Perl source tree to find where this occurs
but have had no luck.

Can someone help me to compile perl without @INC including the /tools


Unsubscribe: See the above information page

More information about the lfs-support mailing list