bash: /tools/bin/su: No such file or directory

Chris Staub chris at
Sun Oct 30 21:02:45 PST 2005

Scott Loewen wrote:
> Chris Staub wrote:
>> You probably have su linked to host libraries. Try running "ldd 
>> /tools/bin/su" and paste the result here.
> Your comment tripped a memory. The more control and pkg mgmt calls for 
> copying su from the coreutils directory to /tools/bin. I didn't know to 
> do this until I had deleted the coreutils build directory, so I just 
> copied su from /bin/su in the non-chroot environment. After I saw your 
> comment I rebuilt coreutils and copied the new su to /tools/bin. 
> Everything worked fine after I copied /tools/lib to /lib. Below are the 
> results of ldd on the new su:
> Results from ldd /tools/bin/su:
>    =>  (0xffffe000)
>    => /lib/  (0xb7fbb00)
>    => /lib/  (0xb7ed1000)
>             /lib/  (0xb7fee000)
> Is it just me or should there be a /tools in front of these paths? I 
> included --prefix=/tools when I ran configure.
> Scott

You shouldn't be copying anything (except of course what the book says su to /tools/bin). Yes, su should have "/tools" in those paths. 
I was about to ask if you recompiled coreutils as the lfs user, but then 
I remembered that you're in the chroot. If you've followed the book's 
instructions, you wouldn't be able to install anything else into /tools 
as the lfs user because you've changed ownership of that directory to 
root. How exactly did you recompile coreutils? From within the chroot, 
as root outside the chroot, or some other way?

More information about the lfs-support mailing list