Kernel panic - not syncing. No init found.

Andreas Åberg andreas at
Fri Oct 28 14:55:48 PDT 2005

Ken Moffat skrev:
> On Fri, 28 Oct 2005, Andreas Åberg wrote:
>> Hi
>> I have compiled a uClibc HLFS system and everything seems to be ok until
>> i try to boot it.
>> (the hda3 gets mounted here without any problem)
>> VFS: Mounted root (reiserfs filesystem) readonly
>> Kernel panic - not syncing. No init found. Try passing init = option to
>> kernel
>> I have googled and tried everything... help!!!
>> I tried to change init to init=/sbin/init and init=/bin/bash and init=3
>> but it has no effect what so ever...
>  What we know so far:
> (i) hda3 does have a reiserfs filesystem.
> (ii)the kernel isn't able to run either /sbin/init or /bin/bash on hda3.
> 1. When you mount hda3 at /mnt/lfs on the host system, do
> /mnt/lfs/sbin/init and /mnt/lfs/bin/bash exist ?  If they don't, is
> the directory structure garbled (e.g. /mnt/lfs/something/bin/bash
> exists), or is it the wrong partition ?
> 2. If they do exist, when you chroot to /mnt/lfs, can you then run
> /bin/bash ?
> Ken
1. Yes they exist.

2. Yes i can run /bin/bash, and everything else to.

More information about the lfs-support mailing list