Grub and gcc-4?

Andrew Benton b3nt at
Wed Oct 26 13:15:50 PDT 2005

Hello people,
Is it just me? or is anyone else having problems with grub compiled with gcc-4? 
I always install grub when I rebuild LFS but I never actually rewrite the MBR, I just edit grub/menu.lst and leave the MBR alone. Tonight I made a mistake though. I wasn't paying attention while I installed OpenSuSE 10 and it rewrote the MBR. Not a big problem. As usual I used a Mandriva install CD to get to a command prompt and then reinstalled grub to point to my normal menu.lst and then rebooted back into LFS. But just to check everything was OK I ran grub again from LFS. It seemed to work fine but when I rebooted I just got a black screen with a little smiley face near the bottom right corner. Very odd. So, once again, fixed it with the Mandriva CD, booted into another version of LFS and tried again. Same result. So I fixed it again and booted into Fedora Core 4. Ran grub there - same result. Fixed it again and booted into Ubuntu-5.10 - same result. The only one that worked was the Mandriva CD or booting into the Mandriva partition and running grub there. I think that the

only one that wasn't compiled with gcc-4 is the Mandriva version.
So does grub work for anyone who's using LFS-SVN with grub compiled with gcc-4? Can you run these commands and reboot?

root (hdx,y)
setup (hd0)

More information about the lfs-support mailing list