oops, how does one re-install gcc?

Tushar Teredesai sukucorp at gmail.com
Tue Oct 18 15:31:48 PDT 2005


On 10/18/05, Matthew Burgess <matthew at linuxfromscratch.org> wrote:
> Tushar Teredesai wrote:
>
> > As long as you are upgrading the toolchain packages (not downgrading)
> > everything should be ok, especially if they have the same major (and
> > minor version?)
>
> I think glibc is still an exception here, though I wouldn't like to bet
> any amount of money on that!  I do, however, agree that _upgrading_ gcc
> and binutils is relatively safe (i.e. I've personally not run into any
> trouble doing so, YMMV of course!).
>

I remember reading on the glibc mailing list that glibc is always
backward compatible, i.e. an application compiled for glibc-2.2 should
work on a glibc-2.3 system.

--
Tushar Teredesai
   mailto:tushar at linuxfromscratch.org
   http://www.linuxfromscratch.org/~tushar/



More information about the lfs-support mailing list