Glibc-20050926

Luca liliana.perossa at fastwebnet.it
Fri Oct 7 08:16:59 PDT 2005


----- Original Message ----- 
From: "Ken Moffat" <ken at linuxfromscratch.org>
To: "LFS Support List" <lfs-support at linuxfromscratch.org>
Sent: Friday, October 07, 2005 4:24 PM
Subject: Re: Glibc-20050926


> On Fri, 7 Oct 2005, Luca wrote:
>
>> Hi all.
>>
>> I'm trying to follow cross-lfs-20051006-x86_64 to build a multilib 
>> system
>> however in chapter 5.7, building cross-tools, I have the following 
>> error:
>>
>
>>
>> checking for x86_64-pc-linux-gnu-gcc... (cached) gcc
>>
>> checking version of gcc... 3.3.5, bad
>>
>
>>
>> configure: error:
>>
>> *** These critical programs are missing or too old: gcc
>>
>> *** Check the INSTALL file for required versions.
>>
>> lfs at SUSE93:/mnt/lfs/sources/glibc-build>
>>
>>
>>
>> Could it be because my host is SuSE 9.3 32 bit, and if not, how to 
>> solve this
>> error?
>>
>
>  I'll take a guess that glibc-20050926 is not 100% friendly to
> cross-compiling.  You did use gcc-4.0.2 to build the cross-compiler,
> didn't you ?  If that's the case, it sounds as if gcc is testing the
> host compiler instead of the cross-compiler.
>
>  I'll take a look, but don't hold your breathe, I'm not good at 
> hacking
> the toolchain.
>
> Ken
> -- 
>  das eine Mal als Tragödie, das andere Mal als Farce
>


--------------------------------------------------------------------------------


> -- 
> http://linuxfromscratch.org/mailman/listinfo/lfs-support
> FAQ: http://www.linuxfromscratch.org/lfs/faq.html
> Unsubscribe: See the above information page
>

On the host gcc version is 3.3.5 but in Cross-LFS you compile it just 
after glibc-headers. Well, I think I will install gcc-4.0.2 on the host 
in opt.

Luca 




More information about the lfs-support mailing list