Step 6.11 - Glibc - tst-rwlock6 error

Jon Fullmer jon at
Thu Oct 6 18:55:49 PDT 2005

Not to beat a tired point, but the more I think about it, the more this
could easily be related to NTP.  It would seem that the glibc tests are
based on the clock it keeps within itself, but also somewhat upon system
time.  If NTP were to do a time adjustment during the test (even a slight
one), it would confuse the test.  Thus, the mysterious "timeout too short"


 - Jon

on 10/6/05 6:20 PM, Jon Fullmer at jon at wrote:

> I'm sorry, I didn't mention that, did I?  I did NOT disable NTP at any time.
> I made no changes to the system.  I followed the procedure that I outlined
> only.
> - Jon
> on 10/6/05 6:14 PM, Dan Nicholson at dbn.lists at wrote:
>> On 10/6/05, Jon Fullmer <jon at> wrote:
>>> Hmm... That's a possibility, as I am running NTP.  Here's what I did,
>>> though:
>>>  - I created a new build directory - glibc2-build
>>>  - As I already applied the patch in the source, I didn't do it again
>>>  - I ran the configure
>>>  - I ran the make
>>>  - I did another make check
>>> This time, it finished.  No errors.
>> So you did shut off ntpd, or not?  If so, I think it may be worthwhile
>> to add to the glibc page that running ntpd may cause false errors in
>> the glibc testsuite.
>> Dan

More information about the lfs-support mailing list