Step 6.11 - Glibc - tst-rwlock6 error

Jon Fullmer jon at
Thu Oct 6 17:10:10 PDT 2005

Hmm... That's a possibility, as I am running NTP.  Here's what I did,

 - I created a new build directory - glibc2-build
 - As I already applied the patch in the source, I didn't do it again
 - I ran the configure
 - I ran the make
 - I did another make check

This time, it finished.  No errors.

That says to me that it probably was a timing issue of some kind.  Anyway, I
just thought I'd let you know my results.

 - Jon

on 10/6/05 10:47 AM, Dan Nicholson at dbn.lists at wrote:

> On 10/5/05, Jon Fullmer <jon at> wrote:
>> I tried to google AND check the LFS site to see if this is something I
>> should be concerned about, but I can't find anything.  What is "timeout too
>> short"?  Does this mean it timed out (something that the LFS book said may
>> happen on older hardware), or is this something more serious?
> Don't know if this will be related at all.  The other day I failed
> glibc test tst-timer4, and it turned out the fault was that the host
> was running ntpd.  When I turned off ntpd and reran the tests, they
> all passed.  So, if ntpd is running, you can turn it off since this
> may affect timing tests.
> Dan

More information about the lfs-support mailing list