LFS 6.1 build and boot problem

Ken Moffat ken at linuxfromscratch.org
Wed Oct 5 13:00:05 PDT 2005


On Wed, 5 Oct 2005, Jeremy Shivers wrote:

> Thanks for the reply.
>
>> Sounds possible, what is your machine ?
>
> P3 600
> 384 RAM
> 24 Gb 5400RPM
> Intel e100 integrated nic
>

  I guess that is 100x6 for the speed, I would have expected it to be 
fast enough for the versions of the toolchain in the 6.1 book.  I did 
build a recent svn LFS (newer than 6.1) on a Celeron 1000 (100x10, but 
probably less cache than you have) and a 5400rpm disk - worked ok, but 
painfully slow.  Oh, wait, did't somebody say the other day that the 
live CD create a filesystem in RAM (which will make things more likely 
to go into swap) ?  I think you are correct that the glibc check failure 
isn't a problem to worry about.

>>   Maybe strange characters in the bootscripts (I would typically expect 
>> "command not found: k: line 2"  type information if the command was called 
>> 'k', but you don't have the ': ' so it looks something weird in the 
>> scripts.)
>
> Same here. I'll check out the bootscripts and see if find any discrepancies.
>
>>   If the bootscripts themselves are correct (which I would expect, because 
>> nowadays we just install them), then perhaps something didn't get built. 
>> Sounds as if the live CD is an automated build (I've never used it), you 
>> might need to ask on the live CD list (or check that you haven't 
>> accidentally disabled something else when you disabled the glibc checks).
>
> 	Yes the process is automated but I assume the commands in the profile 
> are the same as those in the book? Command for command I don't think anything 
> would be different if I was typing them at the keyboard or a program was 
> running them for me. Would it be worth it to build the system manually 
> following each chapter in the book? The automated process takes about 6 hours 
> and 30 minutes to complete. If I remove all gcc "make check"s I can get it 
> down to almost 5 hours. I usually let it run at night. I also checked the 
> md5sum on the bootscripts and everything was ok. Could the scripts somehow 
> get messed up upon install?
>
  As I said, I don't follow the development of the live CD, but I imagine 
the overall process is marginally different from a manual build.  If the 
CD *didn't* normally work, we'd hear about it.  Either you are the first 
person to try this version in anger, or something about your system is 
different.  On my old machines I've seen a number of problems over the 
last year that were down to memory quietly failing - most recently a 
single bit in 900+ MB (didn't have highmem in the config) - the box 
seemed to run fine, but I got odd corruption of a couple of tarballs. 
Running memtest86+ for a few hours will highlight or discount that 
possibility.

> I can verify that I only commented out the "make check"s in the profile.
>
  That's one possibility ruled out, then.

Ken
-- 
  das eine Mal als Tragödie, das andere Mal als Farce


More information about the lfs-support mailing list