LFS 6.1 build and boot problem

Jeremy Shivers shivers53 at hotmail.com
Wed Oct 5 13:32:01 PDT 2005

OK, problem solved!

It was due to corrupt files copied over from the skeleton directory of the 
alfs profile. I downloaded and edited them in Windows which I should know by 
now, screws everything up! Grrrrrr!

: command not foundk: line 2:
: command not foundk: line 4:
: command not foundk: line 6:
This was a result of /etc/sysconfig/clock <- screwed up

...ting hostname to lfshost						[  OK  ]
This was a result of /etc/sysconfig/network <- screwed up

: command not foundork-devices/ifconfig.eth0/ipv4: line 2:
: command not foundork-devices/ifconfig.eth0/ipv4: line 7:
This was a result of /etc/sysconfig/network-devices/ifconfig.eth0/ipv4 <- 
screwed up

After fixing these 3 files, it boots without a hitch!

>   As I said, I don't follow the development of the live CD, but I imagine 
>the overall process is marginally different from a manual build.  If the CD 
>*didn't* normally work, we'd hear about it.  Either you are the first 
>person to try this version in anger, or something about your system is 
>different.  On my old machines I've seen a number of problems over the last 
>year that were down to memory quietly failing - most recently a single bit 
>in 900+ MB (didn't have highmem in the config) - the box seemed to run 
>fine, but I got odd corruption of a couple of tarballs. Running memtest86+ 
>for a few hours will highlight or discount that possibility.

Thanks for your advice. If I didn't come up with a solution I would of 
probably tried that next considering 256M of my ram runs at 133Mhz and the 
other 128M at 100Mhz! ;)

Thanks again,
   J. Shivers

More information about the lfs-support mailing list