Compiling file 4.13 [Zlib error]

Jurriaan Pruis jurpie at gmail.com
Mon Nov 28 22:15:35 PST 2005


Hello,

while compiling file i get this error:

/bin/sh ../libtool --mode=compile gcc -DHAVE_CONFIG_H -I. -I. -I.. 
 -DMAGIC='"/usr/share/file/magic"'   -g -O2 -c -o compress.lo `test -f 
'compress.c' || echo './'`compress.c        
rm -f .libs/compress.lo
gcc -DHAVE_CONFIG_H -I. -I. -I.. -DMAGIC=\"/usr/share/file/magic\" -g 
-O2 -c compress.c -MT compress.lo -MD -MP -MF .deps/compress.TPlo  -fPIC 
-DPIC -o .libs/compress.lo                                     

compress.c:49:18: zlib.h: No such file or directory 
                                                                                                                       
compress.c: In function `uncompressgzipped':
compress.c:253: error: `z_stream' undeclared (first use in this function)
compress.c:253: error: (Each undeclared identifier is reported only once
compress.c:253: error: for each function it appears in.)
compress.c:253: error: parse error before "z"
compress.c:281: error: `z' undeclared (first use in this function)
compress.c:281: error: `Bytef' undeclared (first use in this function)
compress.c:281: error: parse error before ')' token 
compress.c:286: error: `Z_NULL' undeclared (first use in this function)
compress.c:291: error: `Z_OK' undeclared (first use in this function)
compress.c:296: error: `Z_SYNC_FLUSH' undeclared (first use in this 
function)
compress.c:297: error: `Z_STREAM_END' undeclared (first use in this 
function)

I've recompiled without cflags and copied zlib.h to build dir(then i get 
a other error)
what is the problem here what should i do?


--
Jurriaan
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.linuxfromscratch.org/pipermail/lfs-support/attachments/20051129/8cdffdca/attachment.html>


More information about the lfs-support mailing list