Machine hangs on beep

Ken Moffat ken at linuxfromscratch.org
Thu Nov 24 04:01:24 PST 2005


On Thu, 24 Nov 2005, Subhash Chandra wrote:

> Hi,
My system hangs sometimes when my pc speaker beeps.
Like when I try to scroll past the last line in vim, or when it beeps
after I issue shutdown/reboot command or when it beeps at the bash
prompt if I hit tab twise to show the auto complete list etc.

The speaker starts and doesn't stop. Also the HDD activity indicator
lights up. I have to press the reset button to rebbot the pc and I
always endup loosing some files.

I'm using LFS 6.1. I deviated from book only for using package users
approach in chapter 6. I installed a few BLFS packages too and then
some more but the problem existed even before that.

My slack doesn't have this problem.
Just in case, FYI I'm using raid array on ite8212 controller.

  Possibly a wrong kernel driver loaded - I had something very similar on 
ppc64 last week (the kernel misidentifies my sound hardware, and loads a 
module for it - box hangs on any attempt to play a sound, or at the ESC 
key in vim, or on tab completion), solved in my case by not building any 
alsa modules.

  I don't imagine your problem is exactly the same, but it looks like the 
sort of problem you get when a kernel driver pokes at hardware it 
shouldn't touch, so review your kernel config and take out everything 
you don't need.  Of course, if you have the config for slack, you could 
try using that as the input for 'make oldconfig' (add udev support). 
if not, at least review which modules slackware loads.

  Actually, google is full of problems with the ite8212, but they all 
seem to be old, so I _assume_ it got merged from the -ac patches.

Ken
-- 
  das eine Mal als Tragödie, das andere Mal als Farce


More information about the lfs-support mailing list