p54 'make -C ld clean' -> no ld directory

Dan Nicholson dbn.lists at gmail.com
Thu Nov 3 22:20:55 PST 2005


On 11/3/05, Micheal E Cooper <mcooper at miyazaki-mic.ac.jp> wrote:
> If I end up violated etiquette, please tell me and I will change my behavior.

Nicely done so far by my opinion.  You clearly stated your problem and
any additional details you thought would be relevant.  And you already
searched the support docs to see if your problem was addressed.  And
you didn't bring an attitude or pepper your email with capitals or
!!!.  That kind of post will be followed up with a pretty prompt reply
so long as everybody isn't stumped by your question.

> Now onto my problem:
>
> After I went through the bin-utils "configure - make - make install"
> sequence, I tried to execute the commands on page 54:
> make -C ld clean
> But an error tells me that there is no such directory as ld.

Chris Staub's reply pretty much sums it up.  You have to stay in the
binutils-build directory until the whole section is done.  If there's
no ld directory in binutils-build, then either the configure or make
commands may have bombed.  Did you receive any errors?

Just to do a quick follow up on the "commands from wrong directory"
problem.  This happens often to first-timers.  It confused me my first
time.  Read Ch. 5.1 carefully
http://www.linuxfromscratch.org/lfs/view/stable/chapter05/chapter05.html#ch-tools-introduction.
 This tells you many important instructions that are implied through
the rest of the book.

--
Dan



More information about the lfs-support mailing list