Trying to move from Red Hat 8.0 (kernel 1.4) to 1.6

Mike Robinson miker at sundialservices.com
Thu Jun 30 19:28:41 PDT 2005


Please excuse what may seem to be an "RTFM" question.  I promise, promise that 
I -have- looked.

I'm trying to move from Red Hat 8.0 to LFS 1.6.  Obviously this means that I 
am trying to compile the toolchain (specifically at this point glibc) under 
the 1.4 kernel.  I am now confronting the "the chicken or the egg problem" 
that the stated "system requirements" for building an LFS 1.6 kernel say that 
you must already have one.  I do not have the option of shutting this system 
down, booting from CD-ROM and trying to replace the kernel that way.  I need 
to be able to compile the toolchain, and thence the kernel and so-on, doing 
all of the compiles and setup under 1.4.  Then I need to be able to 
successfully boot into 1.6 and move the files into their final locations.

What I do not find is a concise technical explanation of how to perform this.  
In reading the various postings I am keenly aware that the people who are 
talking among themselves have already experienced the "ah hah! moment" 
whereas I have not.  Would one of you therefore kindly point me in the right 
direction?  I'm now stuck at step 5.8 facing "fatal: kernel too old," with a 
thick pile of previous postings that I have read closely, and yet no clear 
idea how to proceed.

Many thanks.




More information about the lfs-support mailing list