Problem re-adjusting the toolchain during chapter 6

towarzysz at comcast.net towarzysz at comcast.net
Fri Jun 10 13:03:01 PDT 2005


I deleted the sources from several other packages, but not the binutils sources or the binutils-build directory. The ones I have now while working on chapter 6 are the ones created during chapter 5 for pass 2

Thanks

Rich K.


> towarzysz at comcast.net wrote:
> 
> >When I typed the command to link binutils to the new libs instead of the ones 
> in the /tools directory, I received the following error
> >
> >root:/tools/binutils-build# make-C ld INSTALL=/tools/bin/install install
> >make: Entering directory `/tools/binutils-build/ld'
> >cd /LFS/tools/binutils-2.15/ld && automake --cygnus Makefile
> >/bin/sh: line 0: cd: /LFS/tools/binutils-2.15/ld: No such file or directory
> >make: *** [/LFS/tools/binutils-2.15/ld/Makefile.in] Error 1
> >make: Leaving directory `/tools/binutils-build/ld'
> >
> >As you can see, rather than installing the system on /mnt/lfs, I did it on 
> /LFS... though I followed virtually every other instruction exactly as it was 
> written in the 6.0 book. My binutils source and binutils-build directories still 
> exist. The problem as I see it is there is no longer a /LFS directory after 
> chroot, so I have to change something to accommodate that...Any help would be 
> appreciated
> >
> >Rich K.
> >  
> >
> Did you delete you sources after you build binutils?
> 
> -- 
> ------
> jim at linuxfromscratch.org
> lfs at jg555.com
> 
> LFS User # 2577
> Registered Linux User # 299986
> 
> -- 
> http://linuxfromscratch.org/mailman/listinfo/lfs-support
> FAQ: http://www.linuxfromscratch.org/lfs/faq.html
> Unsubscribe: See the above information page



More information about the lfs-support mailing list