livecd 6.0.1 hangs during boot

Andre andre at
Fri Jun 10 10:16:03 PDT 2005

I have a pc/104 system based on ZFx86 cpu (486 equiv.) and 64M ram.
has been happily running on it for over a year now. I need to upgrade to
kernel and I figure the easiest would be to use LFS livecd. The problem
that the boot hangs and the last message is:
Freeing unused kernel memory: 456k freed

So, somewhere after the call to 'free_initmem' something goes wrong. I
tried to boot with acpi=off - no luck. And booting with init=/bin/sh
make a difference, therefor I believe that the system gets stuck before
run_init_process calls in .../init/main.c.

I have also tried the slax live cd but it gets stuck much earlier, after
displaying 'BIOS check successful'. However, if I take out my hard disk,
then slax boots up fine !?!

If I boot with slackware 9.1 boot cd, everything is ok, even with my
harddisk attached. So I believe it could be something that is common
the 2.6 kernels.


More information about the lfs-support mailing list