Grub can't find my hard drive

curbyIII at curbyIII at
Sat Jun 4 07:35:08 PDT 2005

This is my first LFS system.  I have completed most of the 6.0 LFS book but have hit a brick wall in section 8.4.  I am only a beginner-intermediate Linux user so I will describe what I have done in as much detail as I can (sorry if it's not relevant).

I currently have windows xp, but I want to dual boot with LFS.  I partitioned my SATA hard drive (using partition magic) into 3 partitions:  windows (sda1), LFS (sda5), and swap (sda6).  I am using Knoppix 3.7 to build the LFS system.  Everything went relatively smoothly until I reached section 8.4.  I ran the grub shell and tried 
root (           followed by a TAB but grub just displayed 
root ( 
without any other completions.  I tried 
root(hd0, + TAB
root(hd1, + TAB
root(hd7, + TAB
and it always returned the same error message:
Error 21: Selected disk does not exist

Beyond hd7 grub returned 
root(hd8, + TAB
Error 12: Invalid device requested

I ran grub in Knoppix and it behaved in exactly the same way.  I looked up the grub documentation and it is not supposed to distinguish SCSI drives from IDE drives.

Any assistance would be greatly appreciated.

Thank you

Switch to Netscape Internet Service.
As low as $9.95 a month -- Sign up today at

Netscape. Just the Net You Need.

New! Netscape Toolbar for Internet Explorer
Search from anywhere on the Web and block those annoying pop-ups.
Download now at

More information about the lfs-support mailing list