Glibc Error

tom giftbound at verizon.net
Thu Jan 27 21:14:51 PST 2005


ok i tried installing it this is what I got:

CC="gcc" /usr/bin/perl scripts/test-installation.pl /sources/glibc-build/
/tools/lib/gcc/i686-pc-linux-gnu/3.4.3/../../../../i686-pc-linux-gnu/bin/ld: 
cannot find -lcidn
collect2: ld returned 1 exit status
Execution of gcc failed!
The script has found some problems with your installation!
Please read the FAQ and the README file and check the following:
- Did you change the gcc specs file (necessary after upgrading from
  Linux libc5)?
- Are there any symbolic links of the form libXXX.so to old libraries?
  Links like libm.so -> libm.so.5 (where libm.so.5 is an old library) are 
wrong,
  libm.so should point to the newly installed glibc file - and there should be
  only one such link (check e.g. /lib and /usr/lib)
You should restart this script from your build directory after you've
fixed all problems!
Btw. the script doesn't work if you're installing GNU libc not as your
primary library!
make[1]: *** [install] Error 1
make[1]: Leaving directory `/sources/glibc-2.3.4-20041011'
make: *** [install] Error 2


On Friday 28 January 2005 12:05 am, tom wrote:
> rt/tst-timer4.out



More information about the lfs-support mailing list