lfs live-cd w/ serial mouse

shudde dev at null.org
Tue Jan 25 03:06:19 PST 2005

Using the latest live-cd from 'gaosu.rave.org', attempting to get gpm or 
mouse-support in X working. Due to the untimely death of my ps/2 mouse 
I'm running an old two-button MS serial mouse.

"gpm -m /dev/input/mice" (and yes I'm specifying the correct -t option 
although I've tried them all) simply fails to initiate the mouse without 
error messages. I looked into creating the /dev/ttyS0 device-file and 
since MAKEDEV doesn't exist on the CD, I've been trying with mknod.

I've attempted all of the following:

mknod -m 666 /dev/ttyS0 c 4 64
mknod -m 600 /dev/ttyS0 c 4 64
mknod -m 777 /dev/ttyS0 c 4 64

Along with a lot of minor variations of the above, always get the same 
error message telling me that gpm can't open the device, no other error 
output is provided. I've tried to chmod & chown the device files to 
everything I can think of without success.

I'm probably missing something inherently simple but any help would be 

More information about the lfs-support mailing list