strange ?

Jeremy Huntwork jhuntwork at linuxfromscratch.org
Fri Jan 21 16:40:48 PST 2005


On Friday 21 January 2005 18:52, Richard Betel wrote:
> On 21 Jan 2005 12:12:23 -0500, tom <giftbound at verizon.net> wrote:
> > I had a problem installing LFS 6.0 so I went back and trying 5.1 so far
> > so good, I dont understand why 5.1 is working but 6.0 is not maybe im
> > not doing something right.
>
> 6.0 requires a newer C compiler and 2.6 kernel to install. As I
> understand it, you need to do the following things:
>
> 1) install gcc-3.X
> 2) use gcc-3.X to compile 2.6.X Linux kernel
> 3) boot the new 2.6 kernel
> 4) install LFS6.0
>
> It might be simplest to get the latest LFS bootable image, and use
> that as a platform to run  ALFS to build 6.0 on your box.

A few things here:

First of all, gcc-3.3.3 is included in LFS 5.1, so if you're building LFS 6.0 
from lfs 5.1.1, there's no need to 'install gcc-3.X' as Richard mentioned.  
Just use it for compiling a 2.6.8.1 kernel.  Secondly, Tom, you're going to 
have to give us more info if you really want support.  Just saying that it's 
not building is not going to cut it.  What exactly are the failures/error 
messages?  Where does the build break?  Thirdly - ALFS is only recommended to 
experienced users.  There's too many things you should understand thoroughly 
before you try to build LFS with it, things that you learn by building LFS 
manually several times first.

--
Jeremy Huntwork



More information about the lfs-support mailing list