More alpha LFS6.0 building woes

Richard Betel emteeoh at gmail.com
Tue Jan 18 08:39:24 PST 2005


On Mon, 17 Jan 2005 22:45:17 -0500, Richard Betel <emteeoh at gmail.com> wrote:
> I was starting to feel like I was in the home stretch:
> -the glibc errors seemed to not be important, at least not to me as
> they were all in the precision of output of functions like atan.
> -the binutils errors didn't seem to stop anything from compiling or
> linking or working.
> 
> but then chapter 6 gcc wouldn't build cleanly! It keeps failing while
> trying to build unwind-dw2.c
> 
> Its weird, because it builds cleanly in chapter 5. I've tried building
> it using chapter 5 options but with --prefix=/usr, and that doesn't
> help! I've filed a bug on the gcc bugzilla (19494) but if anyone has
> any ideas what I've done wrong, I'd love to hear about it.
> 
> I'm gonna go try to make bootstrap and see if that changes anything.
> Not holding my breath though.
> 

Status report: "make bootstrap" fails in the same place! So that didn't work.

I got an email from a gcc developer on my gcc ticket. here is what s/he said:
------- Additional Comments From pinskia at gcc dot gnu dot org 
2005-01-18 14:25 -------
Hmm, the only thing I can think of, is that the build mechenism is
picking up the wrong system header
since this source uses the system headers for the struct sigcontext.
-------

I think this likely means that either I've copied over the wrong
headers from the linux kernel (probably grabbing the i386 header
version instead of the Alpha version) or I've done something similar
with glibc. Would anyone have any suggestions on how to check, what to
look for, etc?



More information about the lfs-support mailing list